You are using an unsupported browser. Please update your browser to the latest version on or before July 31, 2020.
close
Shipping times may be longer due to nationwide shipping delays. We appreciate your understanding.
announcement close button
Home > Portable 5-in-1 Emergency Hub > General FAQs > What version of iOS or Android is required to use a Smart Life device?
What version of iOS or Android is required to use a Smart Life device?
print icon

BodyGuardz Smart Life devices are compatible with:

 

iOS - iOS version 13 or higher is required

 

Android - Android (TBD) or higher is required

Feedback
0 out of 0 found this helpful

scroll to top icon